Завершення роботи

Для виходу з програми можна використати один з таких способів:

Командою Файл-Выход;

Зі системного меню командою Закрыть;

За допомогою клавіатури - комбінація клавіш Alt-F4;

Якщо ви не зберегли робочу книгу, то з'явиться діалогове вікно з попередженням про збереження.

Завдання:

Зберегти таблицю на робочому диску у власному каталозі під своїм
ім'ям.

Створити 2-3 невеликі таблиці з області вашої професійної діяльності.

Зберегти таблиці (одна таблиця - один файл) на робочому диску у
власному каталозі.

Закрити файли.

Вийти з Excel.

 

Лабораторна робота № 3.2. Створення текстових документів

3.2.7. Створення текстових документів

Програма Excel надає широкі можливості для формування складних текстових документів. Для цього використовуються засоби вибору шрифтів, вирівнювання, вибору рамок, заливки, штриховок.

Набір шрифтів визначається операційною системою Windows. Для зміни шрифту можна користуватися піктограмами на панелі Форматування. Крім того, шрифт можна змінити за допомогою послідовності команд: Формат-Ячейки-Шрифт.

 

 


Рис. 14.9 Вікно вибору шрифту

Для вирівнювання змісту комірок використовують піктограми. За допомогою меню функція вирівнювання виконується по послідовності команд Формат-Ячейки-Выравнивание.Ця вкладка контролює розміщення тексту та чисел в таблицях. Вона використовується для створення багатострочних надписів, повторення ряду символів в одній чи декількох комірках, зміни орієнтації тексту.

 

 


Рис. 15.1 Вікно вибору вирівнювання

Excel має 4 формати вирівнювання тексту по вертикалі: По верхньому краю, по нижньому краю, по центру, по висоті. Також дозволяється розміщати значення горизонтально, вертикально зверху вниз або під кутом до 90 градусів за годинниковою або проти годинникової стрілки. Розглянемо можливості вирівнювання по вертикалі та обертання тексту на прикладі (див рис. 15.2):

 


Рис. 15.2 Вирівнювання по вертикалі та обертання тексту

Якщо вводити текст, який мас більшу довжину, ніж довжина активної комірки, то Excel розширює текст за границі комірки при умові, що сусідні комірки не заповнені. Якщо встановити прапорець Переносить по словам, то Excel виведе текст повністю в межах однієї комірки. Для цього він збільшить висоту строки, в якій знаходиться комірка і розташує текст на додаткових строках всередині комірки. Прапорець Объединение ячеек дозволяє задати / відмінити об'єднання декількох комірок в одну.

 

 


Рис. 15.3 Приклад використання форматування за домогою вкладки Выравнивание

 

Розглянемо особливості використання вкладки Выравнивание (див. рис. 15.3). В усіх комірках використовується перенос по словах та вирівнювання по верхньому краю. Деякі комірки об'єднані (наприклад, А1 та В1, С1 та С2).

 

 


Рис. 15.4 Вікно вибору границь

Зміну границь можна виконати як за допомогою піктограм, так і за допомогою меню Формат-Ячейки-Граница. Закладка Граница дозволяє задати розміщення границь та задати тип та колір ліній. При натисненні кнопки Внешние границя розміщується по периметру поточного виділення незалежно від того, що виділена комірка або блок комірок. Якщо виділено декілька комірок, то стає доступною кнопка Внутренние, за допомогою якої можна добавити границі між виділеними комірками.

Границі виглядають більш виразно, якщо на робочому листі немає сітки. Щоб знищити сітку з екрану, треба виконати такі команди меню: Сервис-Параметры-Вид та зняти прапорець в полі Сетка.

 

 


Рис. 15.5 Приклад використання границь різного типу

Для кожної комірки можна визначити фон. Використання піктограми дозволяє залити вибрані комірки кольором. За допомогою меню цю процедуру можна виконати по командам Формат-Ячейка-Вид-Цвет-Узор-Образец.Аналогічно можна скористуватися контекстним меню.

Палітра Цвет дозволяє задати фон для виділених комірок. Якщо вибрати колір в палітрі, не вибравши штриховку або узор, то заданий кольоровий фон з'явиться в виділених комірках. Якщо вибрати в палітрі колір, а потім - узор в палітрі Узор, то цей узор накладається на колір фону.

 

 

Рис. 15.6 Вікно вибору кольору комірки

В Excel є можливість управляти відображенням числових значень і змінювати формат чисел. Для цього використовують закладку Число з меню Формат-Ячейка.

 

Рис. 15.7 Вікно вибору формату числа

При форматуванні чисел використовують наступні формати:

Загальний - в більшості випадках відображає саме те, що ви ввели в комірку крім випадків довгих числових значень, які відображуються в експоненціальній формі.

Числовий — дозволяє виводити числові значення у вигляді цілих чисел або чисел з фіксованою комою і виділяти від'ємні значення за допомогою кольору.

Грошовий - аналогічний числовому формату за винятком того, що замість роз'єднувача груп розрядів він дозволяє управляти виводом символу грошової одиниці, який можна обирати в списку Обозначение.

Фінансовий - аналогічний грошовому формату, але виводить грошову одиницю з вирівнюванням по лівому краю, в той час як саме число вирівнюється по правому краю комірки.

Відсотковий - виводить числа у вигляді відсотків. Десяткова кома в числі, що форматується здвигається на два знаки вправо, а знак відсотка виводиться в кінці числа.

Дробний - виводить дробні значення як звичайні, а не десяткові дроби. Цей формат особливо корисний при введенні біржових цін або вимірювань.

Експоненційний — відображає числа в експоненційному записі.

Текстовий - значення в відповідній комірці буде розглядатись як текст.

Додатковий — це два формати поштових індексів, формат номеру телефону і формат табельного номера. Дозволяє швидко вводити числа без введення спеціальних символів.

 

Приклади різних числових форматів наведені в таблиці:

Таблиця 1.1

 

Любий користувач може ввести свої формати, яких немає серед вище наведених, використовуючи категорію Все форматы,шляхом введення спеціальних символів форматування в полі Тип. В якості основи для побудови власного формату можна використати один з існуючих форматів Excel. Цей формат буде збережений без змін, а новий формат з'явиться в списку.

Автоформатування

Можна значно скоротити час оформлення таблиць, якщо ви будете користуватися раніше заданими шаблонами форматування таблиць- Для цього треба виконати такі дії:

виділити необхідний інтервал;

виконати пункт меню Формат ♦Автоформат;

в вікні діалогу вибрати шаблон форматів таблиць;

при затиснеш на кнопку Параметры програма дозволяє відмінити
вибіркові параметри форматів;

для відміни створеного оформлення знову виділяють таблицю:
Формат-Автоформат-Нет.

 


Рис. 15.8 Вікно вибору автоформату таблиць

Піктограма Копировать формат дозволяє швидко скопіювати формат однієї комірки на іншу або діапазон комірок. Для цього потрібно виконати наступні дії:

Виділити комірку або інтервал, параметри яких треба скопіювати.

Натиснути на піктограму Копировать формат.

Перевести курсор на місце розташування комірок, на які треба
скопіювати формат та натиснути ліву кнопку миші.

 

 

 

 


Рис. 15.9 Приклад застосування автоформату

Копіювання формату можна виконати за допомогою меню. Для цього виділяють комірку або інтервал та виконують копіювання. Потім обирають місце розташування даних, на яких необхідно перевести формат та виконують команди Правка-Специальная вставка-Форматы.

Стиль - сукупність формату числа, типу, розміру шрифту, типу вирівнювання, виду рамки, наявності штриховки та захисту комірки. Можна створити власні стиді за зразком, за визначенням, копіюванням іншої робочої книги. Для роботи зі стилями використовується послідовність команд меню Формат-Стиль.

 

Рис. 16.1 Вікно вибору стилю

Завдання

Створити документ по відповідному варіанту, використовуючи процедури та команди, що вивчались в лабораторних роботах № 3.1, 3.2. При оформленні виконати дії по створенню власного стилю.

Зразок створення текстового документу

Створюємо документ ’’Лаб2.xls’’ за допомогою меню Файл-Создать-Общие-Книга.

В комірку А2 вводимо заголовок "Постачальник: Фірма Руна, м. Вінниця, Хмельницьке шосе 125". Використовуємо шрифт розміром 10, полужирний.

В комірки АЗ-А26 вводимо текстові дані.

Змінюємо ширину стовпчика А так, щоб ввійшли слова Гол. бухгалтер і ширину стовпчика В так, щоб вона закінчувалась одразу після слів "Сума до перерахування" за допомогою миші.

B25;C26 підкреслюємо знизу за допомогою виконання команд меню
Формат-Ячейки-Сетка.

В комірки Е25, Е26 - вводимо текстові дані та форматуємо їх так, що дані ввійшли повністю.

Діапазони А24:Н24; С23:Н23; А13:А21; В13:Е13 - окреслюємо зовні та підкреслюємо потрібні комірки.

Виконуємо копіювання формату В13:Е13 за допомогою піктограми копіювання на формат В13:Е21.

Для діапазону F13:H21 окреслюємо границі сітки.

В13 - назначения рахунку.

Виділяємо та відцентровуємо за допомогою піктограми заголовок в діапазоні В13:Е13.

Вводимо дані в комірки F13, G13, Н13.

Окреслюємо діапазони A22:G 22; Н22; В9:Н11.

А7 переміщаємо в D7.

D8 підкреслюємо знизу.

В Е8 вводимо дані.

Використавши команди Формат-Строка-Висота рядки 13:22 робимо висотою 20.

Перевіряємо вигляд листа за допомогою режимів «Предварительный
просмотр» та «Разметка страницы».

Зберігаємо документ.

Зберегти документ під іншим ім'ям та виконати дії по створенню власного стилю за допомогою команд меню Формат-Стиль.


 

Рис. 16.2

 

Лабораторна робота № 3.3 Формули, масиви, функції

3.3.1 Робота з формулами, масивами та функціями в табличному процесорі Excel

Короткі теоретичні вiдoмocmi

Формули використовуються в листах для виконання обчислень над введеними даними. За допомогою формул ви можете виконати операції суми, віднімання, множення, ділення.

Формула складаеться з одної чи декількох адрес комірок або величин, а також знаку математичної дії. Кожна формула починається зi знаку piвнocтi. Для створення формул використовують математичні оператори, що мають відповідний приоритет:

Зведення в ступінь та вирази в круглих дужках.

Множення та ділення

Додавання та віднімання.

На рис. 16.2 представлено виконання простої формули. При активізації комірки формулу можна побачити в рядку формул. (Рис. 16.2)

 


Рис. 16.2

Комірці можна дати ім'я і використовувати це ім'я в формулі.

Щоб ввести формулу з клавіатури, треба виконати алгоритм:

Виділити комірку, в яку треба занести результат обчислень.

Набрати знак рівності.

Набрати формулу. Вона з'явиться в рядку формул.

Натиснути Еnter або галочку в рядку формул.

Щоб ввести формулу, посилаючись на комірку, треба виконати алгоритм:

Виділити комірку, в яку треба занести результат обчислень;

Набрати знак рівності;

Навести курсор миші на комірку, адресу якої ви повинні занести в формулу.

Адреса комірки з'явиться в рядку формул;

Набрати символ оператора математичної дії;

Аналогічні дії виконати для всіх членів формули;

Натиснути Еnter або галочку в рядку формул.

На рис. 16.2 представлено приклад використання формул з посиланням на адреси комірок.

Результат суми, середнього арифметичного, мінімальну та максимальну величину комірок і кількість комірок в діапазоні можна побачити, якщо ви виділите потрібний діапазон та подивитесь в рядок стану. (Рис. 16.3).

 

 


Рис. 16.3

Для відображення формул на робочому листі треба виконати команди Сервис-Параметры-Вид-Формули.

Для редагування формул використовується алгоритм:

Виділити комірку, де знаходиться формула для правки;

Навести курсор та натиснути кнопку миші в рядку формул або
натиснути клавішу F2;

Для швидкої правки - натиснути на кнопку миші при виділеній
комірці два рази;

Зробити виправлення;

Натиснути Еnter або галочку в рядку формул.
Копіювання формул можна виконати за допомогою кнопок
Копировать, Вставить. Крім того можна виконати такі алгоритми:
Для однієї комірки:

Натиснути комірку з формулою, що потрібно скопіювати.

Натиснути клавішу Сtrl і утримуючи її, перемістити границю комірки до комірки в яку ви хочете скопіювати формулу.

Відпустити кнопку миші.

Для швидкого копіювання формули в діапазон копірок, треба спочатку виділити діапазон комірок, а потім набрати формулу в першій комірці діапазона і натиснути Сtrl +Еnter.

При введенні формул використовуються абсолютні та відносні адреси комірок.

Відносна адреса - це адреса що змінюється при копіюванні формули. Приклад використання відносної адреси представлен на рис. 16.4

Абсолютна адреса - це адреса, що не змінюється при копіюванні формули. Приклад використання абсолютної адреси представлен на рис. 16.5 Щоб адреса була в формулі абсолютною треба натиснути клавішу F4, або просто ввести знак долару.

Для зручності в табличному процесорі Ехcel можна змінити команди перерахувань обчислень. Для цього використовують команди Сервис-Параметры-Вычисления (Рис.16.6).

Масив - це послідовність даних, розташованих у рядку або у стовпчику. Для обробки масивів використовують формули для масивів. Результатом їх роботи є також масив. Наприклад, додаючи масиви 0,5; 2,5; -3,5; та 1,5;-1,5, одержуємо масив 2; 1,5 1,5

Перший елемент останнього масиву одержуємо як результат додавання перших двох елементів першого та другого масивів (0,5 та 1,5). Аналогічно одержуємо останні елементи третього масиву. Масивам можна задавати ім'я і і використовувати в подальшому при звертанні до масиву його ім'я.

 

Рис. 16.4

 

Рис. 16.5 Абсолютна адреса

 

Рис. 16.6

 

Формула для масивів дозволяє виконати множину обчислень, записавши лише одну формулу. Наприклад, у стовпчику А ( з 10 по 15 комірку - дані, що потрібно поділити на відповідний зміст комірок стовпчика В. Тоді в стовпчику С можна розмістити результат частки одного масиву на другий. Алгоритм запису формул для масивів.

Щоб записати формулу для масивів, потрібно:

Виділити комірки, де потрібно розмістити результат

Ввести знак "="

Виділити комірки, де знаходиться перший масив

Ввести знак операції

Виділити комірки, де знаходяться дані другого масиву.

Натиснути клавіші Shift+Ctrl+Enter

При цьому важливо, щоб масиви у формулі для масивів мали однакову розмірність, тобто однакове число стовпчиків і рядків. Внесення змін у формули для масивів виконується так само. Як редагування формул для однієї комірки. Потрібно натиснути кнопку миші на одній із комірок, що містять формулу для масивів та зробити відповідні зміни. При редагуванні формули для масивів фігурні дужки зникають. Вони вказують на те, що маємо справу з формулою для масивів, тому після внесення поправок до формули в одній з комірок потрібно знову натиснути Shift+Ctrl+Enter. Тоді при редагуванні однієї з формул для масивів останні змінюються автоматично.

 

Рис. 16.7

 

Зразок рішення задачі за допомогою формул для масивів.

По даним ціни товару та його кількості визначити суму, на яку придбано товар. (Рис. 16.8). Виконати задачу різними засобами.

Порядок виконання задачі:

Заповнюємо комірки А1:А9; В1:В11; С1:С11 даними в потрібному
форматі.

Виділяємо діапазон комірок, де буде записаний результат.

Вводимо знак рівності.

Виділяємо комірки масиву А.

Вводимо знак множення.

Виділяємо комірки масиву В.

Натискаємо клавіші Shift+Ctrl+Enter

Виконуємо копію даних в окрему таблицю та виконуємо дії з
формулами за допомогою маркеру змісту комірки. Для цього
активізуємо верхню комірку в діапазоні та вводимо формулу для
однієї комірки. Наводимо курсор на правий нижній кут комірки і
після появи маркеру змісту комірки протягуємо по всьому
діапазону.

Виконуємо функцію автосуми.

 

 

Рис. 16.8

 

Лабораторна робота № 3.4 Робота з діаграмами

3.4.1 Робота з діаграмами в середовищі Excel

Типи діаграм

Працюючи в Excel, ви маєте можливість створювати різноманітні типи діаграм. Тип діаграми, що використовується, вибирається в залежності від самих даних і від того, яким чином ви бажаєте їх представити. Нижче наведені основні типи діаграм.

Кругова. Використовується для порівняння частин, що складають ціле.

Лінійна. Використовується для порівняння величин, що змінюються в часі.

Гістограма. Схожа на лінійну діаграму. Використовується для порівняння декількох наборів даних.

Графік. Використовується тоді, коли необхідно простежити модифікацію деякого параметра протягом певного періоду часу.

Крапкова. Схожа на графік. Використовується для порівняння декількох (часто експериментальних) наборів даних, що виводяться в виді крапок.

З областями. Також схожа на графік. Допомагає аналізувати модифікацію значень деякого параметру на визначеному проміжку часу.

Більшість вищезазначених діаграм можуть бути тривимірними. За допомогою таких діаграм зручно аналізувати різноманітні набори даних.

Вбудована діаграма. Дана діаграма розташовується на тому ж аркуші, що і дані, по яких вона побудована. Але її можна винести на окремий аркуш. Вбудована діаграма використовується тоді, коли необхідно розмістити поруч таблицю даних і їх графічне подання.

Спеціальна термінологія

При роботі з діаграмами необхідно знати декілька спеціальних термінів, що представлені нижче.

Діапазон даних. Лінії, сектори і стовбці відповідають деякому діапазону даних в графічному поданні. Наприклад, в лінійній діаграмі зображений ряд однаково наведених стовпчиків, які відповідають певним діапазонам даних. Як правило, всі стовбці одного діапазону мають однаковий колір заливки. Якщо ви виводите на діаграму декілька діапазонів даних, то відповідні стовбці кожного діапазону будуть виділятися своїм кольором. Припустимо, якщо ви відображаєте на діаграмі обсяг продажу, відповідно в області 1 і області 2, то ви задаєте два діапазони даних – свій для кожної області. Часто вони відповідають рядкам таблиці. Так, на рис. 16.9 – діаграма відображає дані першого стовпця таблиці – планового продажу, а в таблиці – представлено продаж як за фактом, так і за планом.

Рис. 16.9 Графік продажу по плану та по факту. Кругова діаграма

 

Ряд. Діапазон даних може розділятися на декілька рядів. Так, в прикладі з обсягом продажу в різних областях для кожного діапазону даних відокремити, скажімо, два ряди. Діапазони даних можуть складатися з декількох рядів або тільки з одного. Звичайно, кожний ряд відповідає серії даних, занесених в окремий стовпчик, і тому часто заголовки рядів співпадають із заголовками стовпчиків в таблицях.

Вісі – це шкали, вздовж яких змінюється діаграма. випадку двомірної діаграми їх дві: вісь Х (горизонтальна) і вісь Y (вертикальна). На вісі Х розташовуються всі діапазони даних і ряди. Якщо діапазон даних включає декілька рядів, то на вісі Х розміщуються надписи, відповідні кожному ряду. На осі Y відображаються значення стовпчиків, ліній або точок, висловлених у відповідних одиницях виміру. В тривимірній діаграмі вісь R направлена вверх, вісь Y відображає ширину діаграми, а вздовж осі Х вказуються значення рядів.

Легенда. Допомагає розрізняти діапазони даних на діаграмі. Наприклад, для кругової діаграми легенда зображається у вигляді виносок з підписами до кожного її сектору.

Лінії сітки. Допомагають аналізувати значення даних. Так, за допомогою горизонтальних ліній сітки можна точніше визначити величину координат на гістограмі.

Створення діаграми.

Ви можете розмістити діаграму на тому ж аркуші, що і дані, по яких вона побудована (вбудована діаграма), або внести її на окремий аркуш. При друкуванні вбудована діаграма розташовується на сторінці поруч з даними. Якщо ви не вставляєте діаграму на аркуш з даними, то вам доведеться роздрукувати її окремо. Але в будь-якому випадку діаграма залежить від даних в таблиці, і тому, якщо ви їх зміните, то діаграма теж автоматично зміниться. Використовуючи кнопку Мастер диаграмм, розташовану на стандартній панелі, ви можете швидко створити необхідну діаграму. Щоб скористуватися послугами Мастер диаграмм, зробіть наступне:

Виділіть дані, по яких необхідно побудувати діаграму. Якщо ви бажаєте включити в діаграму імена груп комірок (наприклад, План, Факт) або інші позначки, переконайтеся в тому, що вони дійсно виділені.

Натисніть на кнопці Мастер диаграмм, розташованій на стандартній панелі.

З‘явиться діалогове вікно Мастер диаграмм з переліком типів діаграм. В списку Тип вкажіть потрібний тип діаграми, а в вікні Вид – необхідний її вид. Після цього натисніть на кнопку Далее>.

З‘явиться друге діалогове вікно Мастер диаграмм, в якому треба вказати джерело даних діаграми і в якому ви можете змінити дані для побудови діаграми. Для цього натисніть на кнопці коагулювання поля Диапазон, розташованій в його правій частині, а після цього вкажіть нові дані.

За замовчанням кожний рядок даних сприймається як новий діапазон. В списку Ряды виберіть опцію Столбцы. В цьому випадку кожний діапазон даних буде відповідати значенням в одному стовпчикові, а не в рядку. Після цього знов натисніть кнопку Далее>.

В третьому діалоговому вікні ви можете вибрати певні опції для діаграми. Наприклад, щоб обрати легенду з діаграми, зніміть прапорець опції Добавить легенду, а щоб додати заголовки діаграми або підпису значень даних, зробіть необхідні установки на відповідних вкладках. Після цього знов натисніть на кнопці Далее>.

В останньому діалоговому вікні Мастера диаграмм вкажіть місце розташування діаграми – на окремому аркуші або на поточному. Вказавши аркуш, на кнопці Готово. На екрані відобразиться діаграма, відповідна вашим даним і зробленим установкам.

Переміщення діаграми і модифікація її розмірів. Для того щоб перемістити вбудовану діаграму, встановіть на ній покажчик миші, натисніть кнопку і перемістіть її в необхідну область. Щоб змінити розміри діаграми, спочатку виділіть її, а після цього перемістіть відповідні маркери (чорні квадратики на її межах) в потрібному напрямі. Щоб змінити висоту і ширину діаграми, перемістіть зовнішній маркер. Слід відмітити, що таким чином неможливо змінити розміри діаграми, що розташовується на окремому аркуші.

Рис. 17.1 Графік обсягу продажу

 

Швидке створення діаграм. Діаграму можна створити більш швидким способом. Для цього виділіть дані, по яких вона буде будуватися, а після цього натисніть <F11>. За замовчанням діаграма буде зображатися в виді гістограми і буде розташована на окремому аркуші. Щоб змінити тип і розташування діаграми, поверніться в вікно аркуша, натисніть на кнопці Мастер диаграмм і зробіть необхідні установки.

Модифікація діаграми за допомогою панелі інструментів діаграми.

Для модифікації діаграми скористуйтесь кнопками панелі діаграми. Якщо дана панель не відображена на екрані, відкрийте меню Вид і виберіть в ньому пункт Панели инструментов. Після цього натисніть на опції Диаграммы.

Рис. 17.2 Майстер діаграм

Збереження діаграм

Створена вами діаграма є частиною робочої книги. Тому, щоб зберегти діаграму, треба зберегти всю книгу, в якій вона знаходиться.

Друк діаграми.

Якщо діаграма вбудована, ви можете роздрукувати її разом з таблицею даних на тому ж аркуші. Якщо ж необхідно роздрукувати одну лише вбудовану діаграму, то спочатку виділіть її, а після цього відкрийте меню Файл і виберіть в ньому опцію Печать. Переконайтесь в тому, що в області вікна вибрана опція Вывести на печать выделенную диаграмму. Після цього натисніть на кнопці ОК. Якщо ви винесли діаграму на окремий аркуш, то просто роздрукуйте відповідний аркуш робочої книги.

Модифікація зовнішнього виду діаграм

Виділення частини діаграми

Діаграма сама по собі складається з декількох незалежних один від одного елементів. Наприклад, в ній можуть вноситися заголовки і легенда, або вона будується не по одному діапазону даних, а по декількох. Перш ніж змінити будь-яку частину діаграми, необхідно спочатку її виділити. Для цього просто натисніть на частині, що вас цікавить або виберіть її в списку

Элементы диаграммы, розташованому на панелі інструментів діаграми. (Щоб відобразити дану панель, відкрийте меню Вид, виберіть опцію Панели

инструментов, а в підменю – Диаграммы.) Означений елемент діаграми обмежується прямокутником з розташованими на ньому маркерами

переміщення (чорні квадратики). Щоб виділити діаграму для редагування, в попередніх версіях Excel необхідно було двічі клацнути на ній. В Excel 97 потрібно клацнути лише один раз. Виділену частину діаграми можна також перемістити на нове місце за допомогою миші. Щоб змінити її розміри, перемістіть межі за маркери в потрібному напрямку. Таким же чином можна змінити розмір всієї діаграми, але спочатку її необхідно повністю виділити.

Модифікація типу діаграми

Щоб змінити тип діаграми (наприклад, Графік на Кругову), виконайте такі дії:

Виділіть за допомогою миші повністю всю діаграму або в списку Элементы диаграммы виберіть Область диаграммы.

Натисніть на кнопці Тип диаграммы, якщо на ній зображена діаграма потрібного вам типу, інакше – на стрілці, що розкриває меню і вже в ньому виберіть необхідний тип.

Якщо, необхідний тип буде відсутній в списку, що розкривається, то щоб задати тип діаграми, який відсутній в списку, виберіть розділ меню Диаграмма і виберіть опцію Тип диаграммы. В діалоговому вікні, що з‘явилось, буде представлений більш повний список – виділіть в ньому потрібний тип.

Додавання легенди і заголовків. Ви можете додати до діаграми декілька різноманітних заголовків, щоб вказати дані, наведені в ній. Заголовок діаграми розміщується на ній. Крім того, ви можете відобразити заголовки вісей діаграми (це стосується трьохвимірних діаграм) і додати до неї легенду – невелику таблицю, що показує колір і назву рядів діаграми. Щоб додати всі вищенаведені елементи, потрібно виконати наступне:

Виділіть діаграму мишею або виберіть область діаграми в списку Элементы диаграмы, розташованому на панелі діаграми.

Відкрийте меню Диаграммы і виберіть в ньому опцію Параметры диаграммы. З‘явиться відповідне діалогове вікно.

Натисніть на корінці вкладки Заголовки, якщо необхідно додати один або декілька заголовків. В правій частині вікна з‘явиться розташований на аркуші заголовок, що вводиться.

Якщо потрібно додати легенду, натисніть на корінці вкладки Легенда. Щоб мати можливість відобразити її, встановіть прапорець опції Добавить легенду, а після цього вкажіть розташування легенди на аркуші.

Виконавши всі необхідні установки, натисніть на кнопці ОК.

Щоб додати до діаграми текст, що не є заголовком, натисніть на кнопці Рисование, розташованій на стандартній панелі. В нижній частині вікна Excel з‘явиться панель Рисование. Натисніть на розташованій на ній кнопці Надпись. За допомогою миші створіть прямокутне поле, в якому буде знаходитися текст. Після цього, як ви відпустите кнопку миші, в середині прямокутника з‘явиться курсор. Введіть необхідний текст. Таким же чином додається текст і в робочий аркуш.

Форматування текстових і числових даних

Будь-який текст, поміщений на діаграму, заноситься у власне прямокутне поле. Щоб змінити формат тексту, розташованого на діаграмі, або числа, по яких вона побудована, треба виконати наступне:

Натисніть на тексті, що необхідно змінити, або виберіть його в списку Элементы диаграммы. Для модифікації тексту всієї діаграми виберіть з списку елемент Область диаграммы.

Натисніть на кнопці Формат выделенного объекта, розташованій на панелі Диаграммы. З‘явиться діалогове вікно, вид якого залежить від виділеного об‘єкта.

Виберіть вкладку Шрифт. Вона містить опції, за допомогою яких змінюються параметри шрифту.

Щоб змінити розташування тексту всередині прямокутного поля, натисніть на корінці вкладки Выравнивание. При необхідності ви можете відобразити текст на аркуші і під кутом.

Щоб змінити формат чисел, натисніть на корінці вкладки Число. В списку Числовые форматы виберіть необхідний.

Змінивши формат, натисніть на кнопці ОК або натисніть <Enter>.

Статья I. Модифікація області діаграми

Щоб покращити зовнішній вид діаграми, можна додати рамку навколо неї, змінити фон області, на якій вона розташовується, і т. п. Щоб змінити вид області, на якій розміщена діаграма, виконайте наступне:

Виділіть елемент, область якого необхідно змінити, або виберіть його в списку Элементы диаграммы, розташованому на панелі інструментів діаграми. Так, щоб змінити фон області діаграми або його межі, натисніть на області діаграми. Для модифікації фона або межі області побудови діаграми виберіть Область построения диаграммы.

Натисніть на кнопці Формат області побудови на панелі діаграми.

Виберіть вкладку Вид.

Щоб змінити вид межі виділеної області, встановіть відповідні опції і області вікна Рамка. Таким чином ви можете змінювати тип, колір і товщину лінії меж. В області вікна Образец відобразяться лінії меж, відповідні зробленим вами установкам.

Якщо вимагається змінити фон виділеної області, виберіть відповідний колір і засіб заливки. Наприклад, натисніть на кнопці Способы заливки і виберіть потрібний тип заливки (Градієнтна, Текстура, Візерунок або Малюнок). В якості фона можна також використати графік, що імпортувався. Виконавши всі необхідні установки, натисніть на кнопці ОК.

Додаткові засоби форматування діаграм

Модифікація сітки

За замовчанням на діаграмах зображаються тільки горизонтальні лінії сітки. Ви можете змінити це і відобразити тільки вертикальні лінії чи одночасно вертикальні і горизонтальні. Крім того, ви можете змінювати значення межі розташування ліній сітки на аркуші і відстань між основними її лініями, а також додавати проміжні.

Основні і проміжні лінії сітки. Орієнтуючись по основних лініях сітки, можна дізнатися приблизні значення даних, виведених на діаграму. Проміжні лінії дадуть можливість більш точно оцінити їх значення. Вони розміщуються між основними.

Модифікація виду сітки. Якщо необхідно змінити вид вертикальних або горизонтальних ліній сітки (або тільки будь-яких одних) або відобразити проміжні, зробіть наступне:

Натисніть на діаграмі. Відкрийте меню Диаграммы і виберіть в ньому пункт Параметры диаграммы. З‘явиться відповідне діалогове вікно.

Натисніть на корінці вкладки Линии сетки.

Виберіть ті лінії сітки, які бажаєте вивести. Приклад діаграми, відповідний вашим установкам, з’явиться в правій частині вікна.

Натисніть на кнопці ОК.

Модифікація шкали значень

Ви можете змінити початкове і кінцеве значення шкали вісі значень (звичайно це Y- вісь), а також відстань між сусідніми лініями сітки, якщо вам необхідно більш чітко поділити на діаграмі різноманітні ряди даних. Для цього виконайте наступне:

В списку панелі інструментів Элементы диаграммы виділіть пункт Ось значений.

Натисніть на кнопці панелі Формат оси.

Виберіть вкладку Шкала.

Вкажіть у відповідних полях максимальне і мінімальне значення даних, що виводяться. Наприклад, якщо встановлено максимальне значення 12000, а максимальне значення даних складає тільки 9800, то для покращення зовнішнього виду діаграми встановіть максимальне значення, що виводиться, яке дорівнює 10000.

Інтервал між сусідніми лініями сітки вказує в поле Цена основных делений. Якщо ви відображаєте і проміжні лінії, то вкажіть в полі ціну проміжних поділок – відстань між проміжними лініями.

Крім того, встановіть точку, в якій вісь Х буде перетинатися з віссю Y. Для цього введіть відповідне значення в поле ось Х пересекается в значении. Якщо необхідно, щоб вісь Х перетинала вісь Y в максимальному її значенні, тоді встановіть прапорець опції Перетин з віссю Х(категорій) в максимальному значенні.

Щоб вивести діаграму з логарифмічною шкалою, встановіть прапорець опції Логарифмическая шкала.

Від‘ємні значення. Якщо на діаграмі відображаються і від‘ємні значення, то опцією Логарифмическая шкала користуватися не можна.

Щоб змінити напрямок вісі значень на протилежний, виберіть зворотний порядок значень.

Після вибору всіх установок натисніть на кнопці ОК.

Модифікація шкали категорій

Ви також можете змінити параметри шкали категорій (вісі Х). Наприклад, треба збільшити відстань між стовпчиками на лінійній діаграмі і т.п. Для цього потрібно виконати наступне:

В списку Элементы диаграммы виберіть пункт Ось категорій.

Натисніть на кнопці Формат оси.

В діалоговому вікні, що з‘явилось, виберіть вкладку Шкала.

Ви можете змінити точку перетину осей Х і Y, вказавши відповідне число в полі Пересечение с осью Y(значень) в категорії номер.

Щоб відобразити на діаграмі кожну другу категорію, в поле Число категорій між підписами поділок введіть 2, щоб відображалась тільки кожна третя категорія, вкажіть в ньому 3 і т.д.

Щоб між підписами поділок відображалося декілька категорій, введіть їх число в поле Число категорий между делениями.

кщо прапорець опції Пересечение с осью Y(значень) між категоріями не встановлений, то на діаграмі не буде додаткового місця між першою і останньою категоріями і вертикальними лініями меж області побудови діаграми.

Щоб змінити порядок виводу категорій на протилежний, встановіть прапорець Обратный порядок категорий.

Якщо необхідно, щоб шкала значень розташовувалася в правій частині діаграми, а не в лівій, як звичайно, то треба встановити прапорець опцій Пересечение с осью Y(значень) в максимальній категорії.

Встановивши всі ці параметри, натисніть на кнопці ОК.

 

 

Модифікація тривимірних діаграм

На відміну від двовимірних діаграм, тривимірні дадуть об‘ємне подання. Щоб відобразити на екрані такі діаграми більш вдало, вам треба змінювати кут їх нахилу або обертати їх. Для цього виконайте наступне:

списку Элементы диаграммы виберіть пункт Углы.

Натисніть на нижньому правому куті.

Щоб повернути діаграму, просто перемістіть кут в потрібну сторону. Замість діаграми з‘явиться прямокутний паралелепіпед, що при переміщенні його куту буде змінювати своє положення.

Вибравши необхідне положення діаграми, відпустіть кнопку миші. Знову з‘явиться вже змінена діаграма.

Модифікація параметрів діапазону даних

Кожному типу діаграм відповідають певні параметри, змінюючи які можна виділити окремі дані на діаграмі. Наприклад, на гістограмі змінюється відстань між категоріями і розмір перекриття (відстань, на які стовпчики різноманітних рядів перекриваються). Слід помітити, що якщо в гістограмі відображається тільки один діапазон даних, то всі стовпчики (за замовчанням) заливаються одним кольором. При необхідності різноманітні стовпчики заливаються різними кольорами. На графіку можна водночас відобразити декілька діапазонів даних різноманітними лініями або використати маркери ліній, а також формат ліній самих графіків для того, щоб розрізняти серію даних. Щоб змінити параметри відображення діапазону даних на діаграмі, виконайте наступне:

В списку Элементы диаграммы натисніть на ряд «Х».

Який ряд необхідно вибрати? Якщо на діаграмі відображається декілька рядів даних, то виберіть в списку необхідний. В деяких випадках не має значення, який ряд ви вибрали, оскільки більшість параметрів однакові для всіх рядів.

Натисніть на кнопці Формат рядов данных.

Хід роботи: По відповідному варіанту задач, що були виконані в першій частині лабораторної роботи 4 побудувати діаграми трьох типів. Виконати зміни в діаграмах та відмітити зміни в таблицях задач.

 

Приклад виконання роботи:

Проаналізуємо табличну інформацію.

Для прогнозу роботи підприємств зручно працювати з графічними даними планового та фактичного обсягу продажу, тому першою діаграмою буде графік планового та фактичного обсягу продажу для заявлених підприємств. Створимо діаграму для вибраного діапазону даних.

1. Виділимо діапазон А2:D8.

2. За допомогою піктограми Мастер диаграмм почнемо побудову діаграми. (Рис. 17.3 Приклад 1)

Рис. 17.3 Приклад 1

3. В діалоговому вікні вибираємо потрібний графік та натискаємо кнопку Далее>.

4. В другому вікні контролюємо вибраний діапазон та ряди діаграми.

5. В третьому вікні вводимо назву діаграми та вісей, можемо змінити формат осей, лінію сітки та легенду. (Рис. 17.4 Приклад 2)

 

Рис. 17.4 Приклад 2

 

6. В четвертому вікні вибираємо місце розташування діаграми – на окремому листі чи в поточному та натискаємо на кнопці Готово. Одержуємо побудовану діаграму. (Рис. 17.5 Приклад 3)

7. Аналогічно вибираємо діапазон даних для інших типів діаграм та виконуємо дії по створенню діаграми. (Рис. 17.6 Приклад 4)

8. На прикладі свого варіанту виконуємо зміни в легенді, форматі діаграм, діапазоні даних по алгоритмам, що представлені в теоретичній частині.

 

Рис. 17.5 Приклад 3

 

 

Рис. 17.6 Приклад 4

 

Лабораторна робота № 3.5 Знаходження коренів

3.5.1 Знаходження коренів налінійного рівняння

Коли потрібний результат обчислень по формулі відомий, але невідомі значення, необхідні для отримання цього результату, можна скористатися засобом Подбор параметра, вибравши команду Подбор параметра в меню Сервис. При підборі параметра Excel змінює значення в одній конкретній комірці до тих пір, поки обчислення по формулі, що посилається на цю комірку, не дадуть потрібного результату.

Візьмемо для прикладу квадратне рівняння х2-5х+6=0. Для знаходження коренів рівняння виконаємо наступні дії:

В комірку С3 (рис. 1) введемо формулу для обчислення значення функції, що стоїть в рівнянні зліва від знаку рівності. Як аргумент використовуємо посилання на комірку С2, тобто =С2^2-5*C2+6.

 

Рис. 17.7 Вікно діалогу Подбор параметра

У вікні діалогу Подбор параметра (рис. 17.7) в полі Установить в ячейке введемо посилання на комірку з формулою, в полі Значение - бажаний результат, в полі Изменяя значения ячейки – посилання на комірку, в якій зберігатиметься значення параметра, що підбирається (вміст цієї комірки не може бути формулою).

Після натиснення на кнопку Ok Excel виведе вікно діалогу Результат подбора параметра. Якщо підібране значення необхідно зберегти, то натисніть на Оk, і результат буде збережений в комірці, заданій раніше в полі Изменяя значения ячейки. Для відновлення значення, яке було в комірці С2 до використання команди Подбор параметра, натисніть кнопку Отмена.

При підборі параметра Excel використовує ітераційний (циклічний) процес. Кількість ітерацій і точність встановлюються в меню Сервис/Параметры/вкладка Вычисления. Якщо Excel виконує складну задачу підбору параметра, можна натиснути кнопку Пауза у вікні діалогу Результат подбора параметраі зупинити обчислення, а потім натиснути кнопку Шаг, щоб виконати чергову ітерацію і проглянути результат. При розв’язанні задачі в покроковому режимі з'являється кнопка Продолжить- для повернення в звичайний режим підбору параметра.

Повернемось до прикладу. Знову виникає питання: як одержати другий корінь? Як і у попередньому випадку необхідно задати початкове наближення. Це можна зробити таким чином (рис. 17,8):

Рис. 17.8 Пошук другого кореня

 

 

В комірку Х (С2) вводимо початкове наближення.

В комірку Хi (С3) вводимо формулу для обчислення чергового наближення до кореня, тобто =X-(X^2-5*X+6)/(2*X-5).

В комірку С4 помістимо формулу, яка задаватиме обчислення значення функції, що стоїть в лівій частині початкового рівняння, в точці Хi.

Після цього вибираємо команду Подбор параметра, де в якості комірки, що змінюється, приймаємо комірку С2. Результат обчислень зображений на рис. 2,б (в комірці С2 - кінцеве значення, а в комірці С3 - попереднє).

Проте все це можна зробити і дещо простіше. Для того, щоб знайти другий корінь, достатньо як початкове наближення в комірку C2 внести константу 5 і після цього запустити процес Подбор параметра.

2. Пошук розв’язку

Команда Подбор параметра є зручною для вирішення задач пошуку певного цільового значення, залежного від одного невідомого параметра. Для складніших задач потрібно використовувати команду Поиск решения (Решатель), доступ до якої реалізований через пункт меню Сервис/Поиск решения.

Задачі, які можна вирішувати за допомогою Поиска решения, в загальній постановці формулюються так:

Знайти: х1, х2, …, хn.

такі, що: F(х1, х2, …, хn)> {Max; Min; = Value}

при обмеженнях: G(х1, х2, …, хn)> {£ Value; ³ Value; = Value}

Шукані змінні – комірки робочого листу Excel – називаються регульованими комірками. Цільова функція F(х1, х2, …, хn), іноді називається просто ціллю, повинна задаватися у вигляді формули в комірці робочого листа. Ця формула може містити функції, визначені користувачем, і повинна залежати (посилатися) від регульованих комірок. У момент постановки задачі визначається, що робити з цільовою функцією. Можливий вибір одного з варіантів:

· знайти максимум цільової функції F(х1, х2, …, хn);

· знайти мінімум цільової функції F(х1, х2, …, хn);

· досягти того, щоб цільова функція F(х1, х2, …, хn) мала фіксоване значення: F(х1, х2, …, хn)= а.

Функції G(х1, х2, …, хn) називаються обмеженнями. Їх можна задати як у вигляді рівності, так і нерівностей. На регульовані комірки можна накласти додаткові обмеження: невід’ємності і/або цілочисельності, тоді шуканий розв’язок шукається в області невід’ємних і/або цілих чисел.

Під цю постановку потрапляє найширше коло задач оптимізації, зокрема розв’язання різних рівнянь і систем рівнянь, задачі лінійного і нелінійного програмування. Такі задачі звичайно простіше сформулювати, ніж розв’язувати. І тоді для вирішення конкретної оптимізаційної задачі потрібен спеціально для неї сконструйований метод. Решатель має в своєму арсеналі потужні засоби розв’язання подібних задач: метод узагальненого градієнта, симплекс-метод, метод гілок і границь.

Розглянемо, як скористатися Поиском решения на прикладі того ж квадратного рівняння.

Рис. 17.9 Вікно діалогу Поиск решения

Після відкриття діалогу Поиск решения (рис. 3) необхідно виконати наступні дії:

У поле Установить целевую ячейку ввести адресу комірки, що містить формулу для обчислення значень функції, що оптимізується, в нашому прикладі цільова комірка – це С4, а формула в ній має вигляд: =C3^2- 5*C3 + 6;

Для максимізації значення цільової комірки, встановити перемикач максимальному значению в положення 8, для мінімізації використовується перемикач минимальному значению, в нашому випадку встановлюємо перемикач в положення значенню і вводимо значення 0;

У полі Изменяя ячейки ввести адреси змінних комірок, тобто аргументів цільової функції (С3), розділяючи їх знаком ";" (або клацаючи мишкою при натиснутій клавіші Сtrl на відповідних комірках), для автоматичного пошуку всіх впливаючих на розв’язання комірок використовується кнопка Предположить;

У полі Обмеження за допомогою кнопки Добавить ввести всі обмеження, яким повинен відповідати результат пошуку: для нашого прикладу обмежень задавати не потрібно;

Для запуску процесу пошуку розв’язку натиснути кнопку Выполнить.

Для збереження одержаного розв’язку необхідно використати перемикач Сохранить найденное решение у вікні діалогу, що відкрилося, Результаты поиска решения. Після чого робочий лист прийме вигляд, представлений на рис. 18.1.

Рис. 18.1 Результати пошуку

 








Дата добавления: 2015-09-07; просмотров: 1511;


Поиск по сайту:

При помощи поиска вы сможете найти нужную вам информацию.

Поделитесь с друзьями:

Если вам перенёс пользу информационный материал, или помог в учебе – поделитесь этим сайтом с друзьями и знакомыми.
helpiks.org - Хелпикс.Орг - 2014-2024 год. Материал сайта представляется для ознакомительного и учебного использования. | Поддержка
Генерация страницы за: 0.181 сек.