Лабораторное занятие № 9. Создание таблиц.

 

ЗАДАНИЕ :

Создать новую базу данных, определить структуру таблиц и заполнить их.

 

Последовательность выполнения лабораторной работы:

1. Загрузить MS Access.

 

Установить переключатель Новая база данных и щелкнуть по кнопке ОК.

Появится диалоговое окно Файл новой базы данных, в котором надо ввести имя новой базы (фамилия-база) и в поле Папка указать путь к своей папке. По умолчанию Access предлагает имя db1. После этого щелкнуть по кнопке Создать. В главном окне Access появится имя новой базы данных.

 

 

2. Чтобы создать таблицу, надо задать поля таблицы и назначить свойства. Создадим свою первую таблицу в режиме Конструктора и присвоим ей имя Склад. В главном окне по умолчанию активной является объект Таблицы. В правой части по умолчанию предлагается команда Создание таблицы в режиме конструктора. Дважды щелкнуть по этой команде или просто нажать клавишу Enter. Откроется окно конструктора таблицы.

В верхней части окна сначала надо ввести имена полей:

- Код,

- Блок,

- Группа товара,

- Вид товара,

- Дата поставки,

- Единица измерения,

- Количество,

- Стоимость единицы.

Обратите внимание, что при переходе к следующей записи Access по умолчанию предлагает тип данных – текстовый. Поэтому для имени поля Код надо щелкнуть в поле Тип данных, при этом справа появляется кнопка с черным треугольником. Щелкнув по этой кнопке, выбрать в списке Счетчик. Для имени поля Дата поставки по аналогии выбрать тип Дата/время. Для поля Количество выбрать тип Числовой, для поля Стоимость единицы выбрать тип Денежный. Для имени поля Блок в поле Описание ввести Складское помещение.

В нижней части окна Свойства поля для каждой записи ввести соответствующие данные:

 

Имя поля Размер поля Формат поля Число дес. знаков
Блок    
Группа товара    
Вид товара    
Дата поставки   Краткий формат даты  
Единица измерения    
Количество целое Основной
Стоимость единицы   Денежный

 

Для имени поля Количество установить свойство поля

Условие на значение >=0 and <=1000, а в свойстве поля

Сообщение об ошибке ввести Недопустимые значения.

Обратите внимание, что при заполнении свойств полей в правой части отображается контекстная подсказка.

 

3. Задание первичного ключа таблицы

До сохранения таблицы следует обязательно определить ключевое поле. Ключевое поле называется также первичным ключом. Каждая таблица должна иметь первичный ключ – одно или несколько полей, однозначно определяющих содержимое других полей.

В нашем случае в качестве первичного ключа будем использовать поле Код, имеющее тип Счетчик. Access при заполнении таблицы для каждой записи в поле код будет присваивать уникальный номер, поэтому даже при копировании записей они будут отличаться по коду.

Выделить поле, используемое в качестве первичного ключа, на панели инструментов щелкнуть по кнопке Ключевое поле.

 

4. Сохранение структуры таблицы

В меню Файл выбрать пункт Сохранить и в ответ на запрос имени ввести имя таблицы Склад. Если не задан первичный ключ, то Access перед сохранением автоматически создает ключевое поле типа Счетчик.

Закрыть таблицу в режиме конструктора, щелкнув по кнопке Закрыть (кнопка с крестиком в правом верхнем углу).

Таблица с именем Склад появится в рабочем поле базы данных.

 

5. Создание таблицы Единицы.

Аналогично создать справочную таблицу «Единицы» с полями: НаимЕдИзм ( текст , размер-10 ). Сохранить.

 

6. Наполнить таблицу Единицы.

Для заполнения таблицы в режиме таблицы надо дважды щелкнуть по значку таблицы Единицы. Появится окно для ввода данных. Ширину полей отрегулировать самостоятельно. Ввести список значений известных вам единиц измерения.

 

7. Изменение структуры таблицы Склад.

Открыть таблицу Склад в режиме конструктора, выбрать поле Единица измерения, в свойствах поля ( внизу конструктора ), в закладке Подстановказадать значения из таблицы Единицы:

- Тип элемента управления – выбрать Поле со списком

- Тип источника строк – таблица или запрос

- Источник строк – вызвать построитель (кнопка ), добавить таблицуЕдиницы,закрыть окно Добавление таблицы, двойным щелчком установить поле НаимЕдИзмв бланк запроса, закрыть запрос крестикомв окне запроса, подтвердить - ДА.

- Сохранить таблицу Складс изменениями.

 

8. Заполнение таблицы в режиме таблицы

Для заполнения таблицы в режиме таблицы надо дважды щелкнуть по значку таблицы Склад. Появится окно для ввода данных. Ширину полей отрегулировать самостоятельно.

Значение счетчика вводить не надо, щелкнуть в поле Блок и ввести название первого складского помещения (например, Блок № 1). После заполнения первой записи щелкнуть в поле второй записи и продолжить ввод. Значения счетчика в поле Код Access устанавливает автоматически (см. таблицу ниже).

В таблице количество складских помещений 2-3, в каждом блоке должно быть 2-3 группы товаров по 3-5 видов товара в каждой группе. Общее количество записей должно быть не менее 30. Количество и стоимость товаров задавать самостоятельно. В разных блоках могут быть одинаковые группы и виды товаров. В таблице не должно быть пустых полей.

Поле Единицы измерения содержит кнопку для подстановки значений из таблицы Единицы.

Меню Формат позволяет задать атрибуты форматирования, упорядочить поля, изменять высоту строк и ширину столбцов, цвет фона и линий сетки. При заполнении таблицы данные сохраненяются постоянно.

При закрытии таблицы в случае изменения параметров надо сохранять все введенные изменения по команде Файл - Сохранить. После заполнения таблицы данными сохранить ее в своей папке и показать результаты работы преподавателю.

 

9. Использование функции Фильтр по выделенному

Access позволяет выполнить быструю выборку записей по выделенному образцу. Например, в поле Группа товара есть три различных группы: Краски, Лаки, Эмали. Если выделить в этом поле любую ячейку со значением Лаки, а затем щелкнуть по кнопке Фильтр по выделенному,

то на экране отобразятся записи только для группы товаров Лаки. При этом на панели инструментов становится активной кнопка Удалить фильтр. Щелчок по этой кнопке, возвращает на экран всю таблицу.

Фильтр по выделенному можно использовать несколько раз подряд, при этом изображаемая на экране таблица становится все короче.

 

10. Использование функции Расширенный фильтр

Если необходимо сделать выборку по нескольким условиям, надо в меню Записи выбрать пункт Фильтр, а затем Расширенный фильтр.

В диалоговом окне выбрать имена полей, по которым будет выполняться фильтрация, а затем ввести условия отбора в нижней части окна. После ввода условий в меню Фильтр выбрать пункт Применить фильтр. На экране останутся записи в соответствии с назначенными условиями.

Щелчок по кнопке Удалить фильтр, возвращает на экран всю таблицу.

Показать преподавателю результаты работы, сохранить базу данных в своей папке, закрыть все открытые приложения и закончить сеанс.









Дата добавления: 2015-05-16; просмотров: 723; ЗАКАЗАТЬ НАПИСАНИЕ РАБОТЫ


Поиск по сайту:

При помощи поиска вы сможете найти нужную вам информацию.

Поделитесь с друзьями:

Если вам перенёс пользу информационный материал, или помог в учебе – поделитесь этим сайтом с друзьями и знакомыми.
helpiks.org - Хелпикс.Орг - 2014-2022 год. Материал сайта представляется для ознакомительного и учебного использования. | Поддержка
Генерация страницы за: 0.011 сек.