Структурирование данных

На листах Excel из данных можно создать в структуру, которая позволит группировать информацию по разделам, сворачивая/разворачивая ее при надобности. Структура может быть как горизонтальной, так и вертикальной и иметь до 8 уровней вложенности. Структуру можно создать вручную, либо автоматически.


При ручном структурировании сначала надо определить нужные элементы – выделить диапазоны ячеек, которые должны быть структурированы, затем применить команду Данные →Структура→ Группировать → Группировать. После выполнения команды, выделенные строки/столбцы становятся разделом. Нажав на знак +, можно увидеть детали раздела, нажав на знак –, можно скрыть лишние детали.

Замечание. Если при сворачивании раздела определенные строки/столбцы должны быть видимыми, их не нужно выделять для группировки.

Автоматическое структурирование используется, когда на листе расположены строки или столбцы итоговых данных или промежуточных итогов. В диапазоне, предназначенном для структурирования, необходимо выделить хотя бы одну ячейку, а затем выполнить команду Данные→Структура→ Группировать →Создание структуры. В результате будет создана структура, использующая итоговые данные как уровни разделов.

Удалить структурирование можно, используя команды ДанныеСтруктура Разгруппировать Удаление структуры.

Фильтрация

В Excel существует возможность отфильтровать список, чтобы вывести только необходимые в данный момент строки. При этом строки, не удовлетворяющие заданным условиям, просто не будут отображаться на экране, а не будут удаляться из файла. Поэтому, отменив фильтрацию данных, можно видеть полностью весь список. Фильтрация может быть выполнена с помощью автофильтра и расширенного фильтра.

Замечание. При копи­ровании данных из отфиль­трованной таблицы будут скопированы только те данные, которые отобра­жаются в данный момент в таблице. Также, если в таблице есть строки с ито­говыми данными, они автоматически будут пересчитываться при каждой фильтрации.

Чтобы применить автофильтр, нужно выделить хотя бы одну ячейку списка данных и применить команду Главная → Редактирование → Сортировка и фильтр → Фильтрили Данные → Сортировка и фильтр → Фильтр. После этого в правом углу ячеек заголовков списка появятся стрелки, нажав на которые можно получить доступ к параметрам фильтрации (рис. 8.3).

Рис. 8.3. Выбор условий фильтрации

Можно наложить фильтр по цвету ячеек, по выбору определенных данных, а также задать различные параметры для фильтрации данных разных типов: числовых, текстовых, дат. Также в автофильтре можно задать два условия отбора данных в одном или нескольких столбцах. Для этого нужно активировать команду Настраиваемый фильтрв меню для конкретного типа фильтра. Удалить автофильтр можно, повторно нажав на копку вызова фильтра.

Расширенный фильтрпредназначен для фильтрации списков тогда, когда возможностей автофильтра недостаточно. Хотя расширенный фильтр и несколько сложнее автофильтра, он имеет ряд преимуществ, основные из них:

Ø можно сохранять критерий отбора данных для дальнейшего использования;

Ø для одного столбца можно задать более двух критериев отбора;

Ø между столбцами можно задать несколько критериев сравнения;

Ø можно показывать в отфильтрованных записях не все столбцы, а только указанные;

Ø в критерии можно включать формулы.

Чтобы отфильтровать список с помощью расширенного фильтра, необходимо произвести некоторые подготовительные действия:

Ø проверить, чтобы столбцы списка имели заголовки;

Ø подготовить таблицу критериев отбора. Заголовки столбцов, для которых будут задаваться условия должны в точности совпадать с заголовками списка, поэтому имеет смысл их просто скопировать из списка. В следующих строках необходимо записать условия фильтрации. Эти строки будут использованы в качестве диапазона условий отбора.

Для объединения критериев с помощью условного оператора И следует указать критерии в одной и той же строке, а для объединения критериев с помощью условного оператора ИЛИ следует ввести критерии в разных строках.


Чтобы применить расширенный фильтр, нужно выделить диапазон фильтрации и вызвать команду Данные → Сортировка и фильтр →Дополнительно.В диалоговом окне Расширенный фильтр(рис. 8.4) нужноуказать место размещения резуль­татов фильтрации (на этом же месте или скопировать в другое), исходный диапазон фильтруемых данных, критерии отбора (диапазон условий), отображение в результате только уникальных записей и нажать ОК. После применения данной команды на листе в указанном месте будут отображены отфильтрованные данные.

Рис.8.4. Окно Расширенный фильтр группы Сортировка и фильтр

Чтобы убрать расширенный фильтр, достаточно нажать кнопку ОчиститьгруппыСортировка и фильтрвкладкиДанные.

<== предыдущая лекция | следующая лекция ==>
ТЕМА 8. ОБРАБОТКА И АНАЛИЗ ДАННЫХ | Создание промежуточных и общих итогов


Дата добавления: 2017-12-05; просмотров: 101; ЗАКАЗАТЬ НАПИСАНИЕ РАБОТЫ


Поиск по сайту:

При помощи поиска вы сможете найти нужную вам информацию, введите в поисковое поле ключевые слова и изучайте нужную вам информацию.

Поделитесь с друзьями:

Если вам понравился данный ресурс вы можете рассказать о нем друзьям. Сделать это можно через соц. кнопки выше.
helpiks.org - Хелпикс.Орг - 2014-2018 год. Материал сайта представляется для ознакомительного и учебного использования. | Поддержка
Генерация страницы за: 0.006 сек.