Условное форматирование вычисляемых значений.

Условное форматирование ячеек применяется, когда необходимо анализировать изменяемые значения результаты вычислений и обеспечить наглядность информации для обобщения.

Условия соединены оператором ИЛИ, задать можно не более трёх условий, в случае выполнения условия ячейка форматируется заданными для условия параметрами.

 

Упражнение 33 (1)

Воспользуйтесь сформированной ранее таблицей «Общие результаты тестирования».

Общие результаты тестирования

Тестируемый Сумма баллов Комментарий
№1 50,00 Успешно
№2 52,75 Отлично
№3 31,25 Неуспешно
№4 35,00 Неуспешно

 

Предусмотрите для варианта суммы баллов формат ячеек:

Курсив, курсив полужирный, цвет шрифта.

В графу «Комментарий» (столбец D) должна быть введена формула:

=ЕСЛИ(C7>$C$2+5;"Отлично";ЕСЛИ(C7>=$C$2;"Успешно";"Неуспешно"))

Согласно формуле в графе комментарий отображается один из трёх вариантов результата. Предусмотрите для каждого варианта формат ячеек:

Можно попросить ввести эту формулу, затем задать условный формат.

=ЕСЛИ(C3>=СРЗНАЧ($C$3:$C$8);ЕСЛИ(D3<=СРЗНАЧ($D$3:$D$8);10%;0);0)

 

Некоторые действия с таблицами

Упражнение 34 (1)

Сортировка.

Создайте или используйте готовую таблицу «Зачисление в команду».

Зачисление в команду

Фамилия Имя Уровень подготовки Успеваемость Результат
Тимофеев В. + + Зачислен
Козырев Ю. + + Зачислен
Ястребов А. + + Зачислен
Жукова Е.      
Ковров И.      
Маратова С.   +  
Мартынов А. + + Зачислен
Маратов Ю. +    

 

§ Необходимо изменить порядок строк так, чтобы строки были сгруппированы по результатам, и внутри группы фамилии упорядочены в порядке алфавита.

В диалоговом окне «Сортировка диапазона» установите:

«Идентифицировать поля по» - подписям,

«Сортировать по» - столбец «Результат», порядок сортировки любой,

«Затем по» - столбец «Фамилия», порядок сортировки по возрастанию.

Упражнение 35 (1)

Сортировка. Пользовательский порядок сортировки.

Создайте таблицу, введите даты семинаров с помощью автозаполнения при условии - семинары проводятся один раз в неделю.

§ Создайте формулы преобразования даты в номер дня недели и месяца, примеры формул: =ДЕНЬНЕД(C33;1) =МЕСЯЦ(C33)

Присвойте имя «Темы» диапазону, содержащему темы семинаров.

Учебный план

Тема семинара Дата семинара День недели Месяц
'Windows 10.10.02
Абзац 31.10.02
Колонки 14.11.02
Оглавление 05.12.02
Основы 24.10.02
Слияние 26.12.02
Список 07.11.02
Стиль 21.11.02
Структура 28.11.02
Таблицы 12.12.02
Шаблоны 19.12.02

§ Создайте пользовательский порядок сортировки, задающий расположение названий изучаемых тем в порядке их изучения, импортируя значения блока «Тема».

§ Упорядочите строки по темам, затем выполните сортировку, применив созданный вариант сортировки.

§ Создайте пользовательский список имён своих знакомых, сторон света – Север Юг Запад Восток.

Упражнение Х (1)

Поиск. Замена. Перейти. Найти.

К именованному диапазону, ячейке этого и другого листа той же книги; по адресу. Изменить масштаб и перейти.

В формулах заменить Успешно на хорошо, неуспешно на посредственно.

Упражнение 36 (1)

Защита ячеек и листов.

Создайте или используйте готовую таблицу «Состав затрат предприятия автосервиса».

Состав затрат предприятия автосервиса
оказание услуг

Наименование статьи затрат Себестоимость, руб. Расчётные проценты от себестоимости, минимум Расчётные проценты от себестоимости, максимум
Материальные затраты 72 000р. 29,40% 40,40%
Фонд оплаты труда 36 000р. 20,20% 34,20%
Отчисления в социальные фонды 13 860р. 7,80% 13,20%
Амортизация основных средств 8 640р. 3,50% 4,80%
Прочие расходы 47 814р. 19,50% 26,80%
ИТОГО 178 314р. 80,40% 119,40%

 

§ Создайте формулы расчёта итоговых значений.

§ Выделите цветной рамкой графу «Расчётные проценты от себестоимости, минимум», затем, оставив незаблокированными значения графы, защитите лист.

§ Создайте копию листа, снимите защиту листа, снимите защиту ячеек, выделив предварительно весь лист.

§ Ячейкам графы «Себестоимость» задайте цвет фона, заблокируйте от изменений значения. Добавьте к заголовку графы выноску с поясняющим текстом.

§ Скройте формулы.

§ Защитите лист и назначьте пароль «АВС» от несанкционированного снятия защиты.

Напоминаем. Защита листа и книг устанавливается и снимается командами меню Рецензирование| Защитить лист/книгу. Блокировка от изменений содержимого предварительно выделенных ячеек устанавливается и снимается в окне команды Формат| Формат ячеек| вкладка Защита.

Справка. Выноска - автофигура панели инструментов Рисование.

Упражнение 37 (1)

Копирование таблиц. Перемещение. Специальная вставка.

Вернёмся к таблице «Состав затрат предприятия автосервиса», в книге «Затраты Автосервиса».

§ Перекопируйте в другой лист только формат.

§ Перекопируйте в другой лист только значения.

Перекопируйте таблицу в буфер обмена, затем с помощью команды Правка| Специальная вставка вставьте в любой пустой лист этой же книги отдельно формат таблицы и отдельно значения таблицы.

Создание новой таблицы на базе существующей.

Выделите первую третью и четвертую графы таблицы и перекопируйте в тот же лист, переместите таблицу на несколько строк ниже, затем переместите в следующий лист.

 









Дата добавления: 2015-01-10; просмотров: 466; ЗАКАЗАТЬ НАПИСАНИЕ РАБОТЫ


Поиск по сайту:

При помощи поиска вы сможете найти нужную вам информацию, введите в поисковое поле ключевые слова и изучайте нужную вам информацию.

Поделитесь с друзьями:

Если вам понравился данный ресурс вы можете рассказать о нем друзьям. Сделать это можно через соц. кнопки выше.
helpiks.org - Хелпикс.Орг - 2014-2021 год. Материал сайта представляется для ознакомительного и учебного использования. | Поддержка
Генерация страницы за: 0.008 сек.