Задание 1. Создание пользовательского меню для текстового редактора. Обработка пунктов меню Правка.

Практически во всех встречающихся программах имеются пункты меню «Файл», «Правка» и т.п. Подпункты меню «Файл» отвечают за работу с файлами, а меню «Правка» – за работу с содержимым текстового или иного файла.

Чаще всего в пункте меню «Правка» содержатся такие команды, как «Копировать», «Вставить», «Вырезать», «Удалить».

В предыдущей лабораторной работе Вы уже познакомились с тем, как создается пользовательское меню. В ходе выполнения данной лабораторной работы Вы активизируете навыки создания подобного меню, а также научитесь создавать и обрабатывать наиболее распространенные команды меню, относящиеся к работе с текстовыми файлами.

Постановка задачи.

Поставим задачу: создать простейшее приложение, содержащее пользовательское меню, состоящее из пунктов меню «Файл» и «Правка». Пункты меню «Правка» должны позволять осуществлять с файлами, точнее, с их текстовым содержимым, следующие действия:

· копировать содержимое выделенного текста в буфер обмена;

· вырезать выделенное текстовое содержимое файла;

· удалять выделенное текстовое содержимое файла;

· вставлять текстовое содержимое из буфера обмена;

Вид подобного приложения (вид пунктов меню «Файл» и «Правка») приведен на Рис.15.1 и 15.2.








Дата добавления: 2015-06-12; просмотров: 409; ЗАКАЗАТЬ НАПИСАНИЕ РАБОТЫ


Поиск по сайту:

При помощи поиска вы сможете найти нужную вам информацию, введите в поисковое поле ключевые слова и изучайте нужную вам информацию.

Поделитесь с друзьями:

Если вам понравился данный ресурс вы можете рассказать о нем друзьям. Сделать это можно через соц. кнопки выше.
helpiks.org - Хелпикс.Орг - 2014-2019 год. Материал сайта представляется для ознакомительного и учебного использования. | Поддержка
Генерация страницы за: 0.004 сек.